ZIBRA™

Zibrao Liquads 1.4.4,

plugin documentotion

v4|=1 7.y R[e]V]]alS] IS A PLUGIN FOR THE UNITY ENGINE. IT ALLOWS THE USE

OF REAL-TIME LIQUID SIMULATION (GPU) POWERED
BY Al BASED OBJECT APPROXIMATION.

Features Zibra Liquids Free Zibra Liquads
Mobile support (i0S) >< M'
Particle count limit 2 min 10 min

Analytic colliders (simple
shapes like cubes, spheres upto 5 unlimited
and bowls)

Neural colliders (arbitrary >< Zr

geometry as collider)

Collider friction >< Z'

Force interaction setting >< Z'

Liquid emitters 1 unlimited
Liquid voids X V1

Liquid detectors >< ZV

Liquid force fields Radial (only one instance) Radial, Directional,

Swirl (unlimited)

Liquid initial state baking X V]

’dn — A‘
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Monipulotors

Liquid Initiol Stote Balking
(experimental)

Registering Zibra Liquids

Troubleshooting
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Editor platforms: PC (DX11/DX12, x86 and x64), macOS(Metal, x64 and arm64)
For M1 Mac users, the Apple Silicon version of Unity Editor is strongly recommended.
Build platforms: PC(DX11/DX12, x86 and x64), UWP(DX11/DX12, x86 and x64),
macOS(Metal, x64 and arm64), iOS (iOS version 12 or later, iPhone 6s or newer)
Unity version: 2019.4 or later (use the latest feature update)

VR is unsupported

Supported Render Pipelines: SRP, URP, HDRP

URP: 7.5 or later

HDRP: 7.x or later




Creote Zibro Liquad

To create a Zibra Liquid instance:
1. Open the Hierarchy window
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2. Right click where you want to add a Zibra Liquid instance

3. Click on the “Zibra -> Zibra Liquid” option.

P New Scene
& 1Camera

ctional Light

Duplicate
Delete

Create Empty
3D Object
Effects
Light
Audio
Video
ul
Ul Toolkit
Camera Zibra Liquid Emitter

Zibra Liquid Void

Zibra Liquid Detector

vov v v v v v

Wisual Scripting Scene Variables

After that, In the Inspector window, you'll see the Zibra Liquid parameters:

+ Zibra Liquid

Reflection probe is not set. Liquid will not render properly.

i Edit Container Area

ontainer Size
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After that you need to set the “Reflection Probe” parameter. On SRP/URP it’'s strongly
recommended that you set this parameter, but is not strictly necessary. On HDRP you
must set a reflection probe before you can use the liquid instance.

You can check which render pipeline you are using by looking at the “Current render
pipeline” message - on the screenshot the SRP is shown.

On SRP, after setting the reflection probe, you’ll no longer see any errors/warnings.

Z v Zibra Liquid

b Edit Container Area

Container Size

Colliders

List is Empty

Add Collider

The list is empty.

Manipulators
Add Manipulator

The list is empty.

Maximum Allowed Timestep
Simulatio
Itera ‘ar Frame
Max particle count
cluticn
Effective grid resolution: (128, 128
Run Simulation
Uze Fixed Timestep
Enable Render Downscale
n Probe & Reflection Probe (Reflection Probe)

Initial State
Current render pipeline: &

Approximate VRAM footprint
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Additional setup on URP

If you are using URP you’ll see those messages:

7 v Zibra Liquid

URP Ligui aring Component is no 1. will not bea re 1, But will still ba simulated.

[ | R Tp—

You need to add “URP Liquid Rendering Component’ to your Universal Renderer asset.
You can find your Universal Renderer asset by following these steps:
1. Navigate to “Edit -> Project Settings...”

Edit Assets GameObject Component Zibra Al Utilities ]
r

Undo Select UniversalRenderer (A... Ctrl+Z
Unde History Ctrl+U
Select All Ctri+A
Deselect All Shift+D
Select Children Shift+C
Select Prefab Root Ctrl+Shift+R
Invert Selection Ctrl+]
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Duplicate Ctrl+D
Rename

Delete

Frame Selected F
Lock View to Selected Shift+F
Find Ctrl+F
Search All... Ctrl+K
Play Ctrl+P
Pause Cirl+Shift+P
Step Ctrl+Alt=P
Sign out

Selection >
Project Settings...

Preferences...

Shortcuts...

Clear All PlayerPrefs

Graphics Tier >
Rendering >

2. From there go to Graphics
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Graphics

Scripta Render Pipeline Settings

i UniversalRP-HighQuality (Universal Render Pipeline A

Built-in Shader Settings
Always include

Always Included Shaders

3. Scriptable Render Pipeline Settings is your current Universal Render Pipeline Asset.
Open that asset in Inspector (you can do it by double clicking it in project settings)
You'll be able to see your Universal Renderer there

Rendering

renderer Data)

ue Texture

Terrain Holes

Quality
Lighting
Shad
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4. Openitin the Inspector (by double clicking)

Forward

Disabled

Auto

Renderer Features

Add Renderer Feature

(Specific Ul elements can vary from version to version)

From there you can finally add “URP Liquid Rendering Component”.

Add Renderer Feature
Render Objects (Experimental)
Decal
Screen Space Ambient Occlusion

Screen Space Shadows

Liquid URP Render Component

If you did everything correctly, error in Zibra Liquid will disappear:

Z + Zibra Liquid

Fi Edit Container Area

Note that adding “URP Liquid Rendering Component” is project wide, and is only
needed once.
Lastly: on URP, liquid will only be rendered in Game view, including the baking utility.

K . U 2.
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Additional setup on HDRP

If you are using HDRP you’ll see this message:

# v Zibra Liquid

On HDRP you also need to set the Custom Light parameter.
This parameter sets which light will be used for the liquid lighting.
Currently, only 1 light can be used for lighting the liquid.

Render Downscale
1 Light Mone (Light)
ion Probe A Reflection Probe (HD Additional Reflection Dat &

Ma Particles -

After setting the Custom Light parameter the error message will disappear:

# « Zibra Liquid

b Edit Container Area

Container Size
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After creating Zibro Liquid

You can now press play, and see liquid (in URP you can only see liquid in Game View,
on SRP/HDRP you can see liquid in both the Scene and Game Views)
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Also, you can check out how the fluid works in the built-in demo scene. To do that,
open the Project window and go to Assets -> Plugins -> Zibra -> Liquids -> Samples
and open the SampleScene.

Note that the sample scene is for SRP, and in URP and HDRP non liquid objects may
look incorrectly.

Assets » Plugins » Zibra » Liguids » Samples

.....@@B

Materials Samplase. samplasec. 5 SamplasSc... Samplass... ZibraAlLiqu..

In the sample scene you can see various features of Zibra Liquid.

K . U 2y
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You can move the camera with WASD, control gravity with arrows, remove gravity with
O, increase and decrease gravity with Shift and Ctrl
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Liquid poarometers

Moin parometers
e Container size
# + Zibra Liquid
b Edit Container Area

Container Size

The Container size parameter changes how large the simulation volume of
liquid is.

You can press “Edit Container Area" to enable resizing gizmos.

This parameter cannot be changed on the “live” liquid instance.




LIBCSIIBBSIBBRAY

sntainer Area

This parameter specifies what the highest delta time that may be used in
simulation is, when the FPS drops. If that limit is hit, liquid simulation will slow
down.

Higher values correspond to less stable simulation during FPS drops, but will
result in less cases when the liquid noticeably slows down.

K . U 2y
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e Simulation speed

Simulation speed

This parameter controls the speed of the liquid simulation. You can slow down
or speed up the liquid with this parameter.

e lterations per frame

[terations Per Frame

Controls how many physic steps will be calculated each time. This severely
affects performance, but results in slightly better simulation quality. In most
cases you will want to set it to 1.

e Max particle count

Max particle count

Controls how many liquid particles a liquid instance can have at the same time.
Higher values correspond to a higher possible liquid volume, but results in
higher VRAM usage and a higher performance cost.

This parameter cannot be changed on the “ive” liquid instance.

e Grid resolution

This parameter controls the size of the liquid simulation grid.

Higher size of the grid corresponds to a higher quality simulation, and the
smaller size of each particle, but results in higher VRAM usage and a higher
performance cost.

Effective grid resolution shows you the 3D size of your liquid grid. VRAM usage
and performance cost scales with effective grid resolution.This parameter
cannot be changed on the “live” liquid instance.

e Run simulation

Run Simulation

Freezes the liquid when disabled. Also decreases performance cost when
disabled, since we don’t do physics simulation.

e Use Fixed Timestep

se Fixed Timestep

Use Fixed Timestep for physics simulation. Can be used to have almost
identical behavior of liquid between different runs and machines. Use with care,
if the physics simulation takes more time than Fixed Timestep, performance will
be severely affected.

K . UY 22X
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e Visualize Scene SDF

Visualize Scene SDF

Allows you to visualize analytical and neural colliders. Only works when the
Current Rendering Mode is set to Particle Render.
e Enable Render Downscale

Enable Render Downscale

Downscale Factor

Enables the usage of lower resolution for liquid rendering. The Resolution scale
is controlled with the “Downscale Factor”. Recommended for mobile devices.

e Reflection probe

Reflection Probe & Reflection Probe (Reflection Probe)

Sets reflection probe used for reflection calculation on liquid. Must be set on
HDRP, and it's strongly recommended to be set on SRP/URP.

e Current Rendering Mode

Current Rendering Mode Mesh Render

Selects which renderer is going to be used for this instance of the liquid. The
default and recommended one is Mesh Render. It has better visuals, especially
in regards to semi-transparent liquids. Certain options are only available in
specific Render modes.

e Current Injection Point

Current Injection Paint Before Forward Alpha

Specify at which point in the render graph should liquid be rendered.
Recommended options are: Before Forward Alpha if you want other transparent
objects to be rendered on top of the liquid, or After Forward Alpha if you want
liquid to be rendered on top of the other transparent objects.

Materiol porometers

e Materials

Fluid Material & FluidMaterial

Upscale Material % UpscaleMaterial

Materials used to shade liquid surface, and optionally upscale liquid when the
Enable Render Downscale is enabled. Most users will not change that option.
To use it you will need to create your own custom version of FluidMaterial, and
potentially UpscaleMaterial as well. If it is set to None in Editor it will revert back
to the default value.

K . UY 2.



LIBBSLIBBA"

e Color

Liquid color.

o Reflection Color

Reflection Color HD E

Tint for reflections on the water.

e Roughness

Roughness

How rough is the liquid surface. Normally, for liquids that parameter is really
low.

e Metalness

How metallic (reflective) the liquid surface is.

e Scattering amount

Scattering Amount

Defines how much light gets scattered inside the liquid. Higher values
correspond to more opaque murky liquid. Only used in Mesh Render.

e Absorption amount

Absorption Amount

Defines how much light gets absorbed inside the liquid. Higher values
correspond to more opaque liquid.

e Index of Refraction

Index OFf Refraction

Determines how refracted the light coming through the liquid will be.

e Fluid Surface Blur

Fluid Surface Blur

Determines how smooth the surface of liquid will appear.

e Particle scale

Particle Scale

Scale for particle rendering. Lower values correspond to more detail, but more
artifacts. Needs to be at least ~1.5 to achieve a believable render. If set to very
low values you’ll see each individual particle. Does not affect simulation, it only

K . UY 2SE.
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affects rendering. Only used in Particle Render.

e Foam parameters

Foam Intensity

Foam Amount

Configure what the threshold is for foam appearance and how intensive it is.
Only used in Particle Render.

e Blur radius

Blur Radius

Configures how strong the particle blur is. Lower values result in more detail,
but the individual particles become more distinct. Only used in Particle Render.

Advanced Material porometers

e Refraction Quality

Refraction Quality Per Pixel Render

Configures how the refraction will be calculated, for each vertex or for each
pixel. Per Pixel Render has higher quality but also higher performance impact.
Only used in Mesh Render.

e Refraction Bounces

Refraction Bounces

Configures how many refraction bounces will be calculated. Two Bounces has
higher quality, especially when underwater, but also has a higher performance
impact. Only used in Mesh Render.

e JFA lterations

JFA Iterations

Configures how many iterations of the JFA algorithm used for Particle render
will be executed. Higher values correspond to less pixel artifacts when close to
the liquid. Higher values have a high performance impact. Only used in Particle
Render.

e Vertex/Mesh optimization parameters

Configures how much smoothing will be applied to the liquid surface. Higher

K . UY 22X
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iterations count corresponds to higher quality but has a slightly higher
performance impact. Higher Step values correspond to more smoothing but
potentially more artifacts. You can set all those values to 0 to get voxel liquid.
Only used in Mesh Render.

e Iso Surface Level

Configures how thick the surface of liquid will appear.

e Raymarching parameters

Configures how liquid is raymarched for refraction/liquid depth calculations. If
misconfigured it can result in opaque liquid or bad refraction. Higher values of
Iso Surface parameter correspond to thicker liquid surface for the purpose of
that calculation. Higher Max Steps count corresponds to higher quality and less
artifacts but has higher performance impact. Higher values of Step Size and
Step Factor allow you to decrease Max Steps parameters, but corresponds to
more artifacts.

Solver parometers

e Gravity

Gravity that affects the entire liquid.

e Fluid stiffness

Fluid Stiffness

Configures how stiff the liquid appears (how resistant it is to compression).
Higher values are not recommended.

e Particle density

Particle Density

Configures the resting particle density. Higher values result in smaller particles,
which result in higher quality, but smaller liquid volume.

K . UY 22X
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Velocity limits

Maximum Velocity

Minimum Velocity

Limits the maximum/minimum velocity of the particles. Setting minimum velocity
to values higher than 0 results in liquid that will never stop.

Viscosity

Configures how viscous the liquid is (how hard it is to change the shape of the
liquid)

Surface tension

Surface Tension

Configures the surface tension of the liquid. Higher values result in liquid that
tries to merge together. Negative values result in liquid that tries to split into as
many small liquid parts as possible, resulting in a spaghettification effect.

Force interaction strength

Force Interaction Strength

Scales the force that the liquid applies to objects with force interaction enabled.
This has a logarithmic scale.
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Zibra Liquid has 2 types of colliders: Analytic and Neural colliders.
Analytic colliders are simple shapes: cubes, spheres, capsules, torus, cylinders.
Neural colliders are created from arbitrary mesh.

Adding Analytic Colliders

To add analytic collider:
1. Create a new GameObject, either of your selected shape or an empty one:

ra Li 1
TR Cut

Rename
Duplicate
Delete

Select Children
Set as Default Parent

Create Empty
Create Empty Parent |
Cube
Effects
Light Capsule
Audio Cylinder
Video Plane
ul Quad
Ul Toelkit
Zibra

Text - TextMeshPro

Legacy
Camera

Visual Scripting Scene Variables Ragdoll...
Move To View

Align With View

Terrain

Tree
Align View to Selected Wind Zone

Toggle Active State

Properties...
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2. Open Inspector for newly created GameObject

Layer Default

Bl  sphere (Mesh Filter)

Mesh

Eﬁ « Mesh Renderer

Materials

Lighting

Probes
Light Probes Elend Probes
Refl 5 Elend Probes

Mone (Transform)

Per Object Motion

Dy namic lusion v

< Sphere Collider

Edit Collider

W ELEE] Maone (Physic Material)

' Default-Material (Material)

Add Component
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3. Press add component, and add “Zibra Analytic Collider

Add Component
2, Zibra Analytic Collider

Search

77 Zibra Analytic Collider

Mew script

4. Select the correct “Chosen SDF Type”

.~ Zibra Analytic Collider

Chosen SDF Type
Fluid Fricti Sphere
Force Interactio Box

Invert SDF

Capsule

' Default-Material (Material Torus

Cylinder

5. Open the Inspector window for Zibra Liquid and Press the Add button for your
newly created collider.

Colliders

Add Collider

Add all

Note that you may have multiple liquid instances within a single scene, with a
separate list of colliders. So you don’t necessarily need to add all of the
colliders to your liquid instance if you have more than 1 liquid instance.

6. You can now expand the full list of Colliders and see your colliders there

Colliders

Element O T.Sphere (Analytic SDF Collider)

After that your collider is ready to be used. You can set its transform in the editor, or
move it at runtime.

K . U 2N
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Adding Neural Colliders

Before you can use the Neural Colliders functionality you need to register the plugin:
Registering Zibra Liquids

To add a neural collider you first need to have the mesh that you want the water to
collide with. In this example we’ll use a teapot as an example.
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1. Open your GameObject with MeshFilter in Inspector

Layer Default

Default (Mesh Filter)

default

Eﬁ + Mesh Renderer

Materials

aal Humination

Blend Probes
Blend Probes

Mane (Transform)
Per Object Motion

Dynamic io

' Default Mat (Material)

Add Component

2. Press “Add Component” and select “Zibra Neural Collider”
Add Component
a Zibra Meural Collider]
Search

* Zibra Meural Collider

MNew script
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3. You should see these buttons:

¥9 ~ Zibra Meural Collider

Collider doesn't have representation.

Generate collider

Add Unity Collider
Fluid Friction

Force Interaction

Invert SOF

If you don’t see them, you probably haven’t registered your plugin yet. Register
your plugin: Registering Zibra Liquids and try again.

4. Press Generate Collider. This will send your mesh to ZibraAl servers for
processing. This will generate neural representation for your mesh. After the
generation has finished you'll see a message: “Collider already generated”, as
well as the VRAM footprint of the collider.

K% ~ Zibra Meural Collider
Collider already generated.

Regenerate collider

Add Unity Collider
Fluid Friction
Force Interaction

Invert SDF

5. Open the Inspector window for Zibra Liquid and Press the Add button for your
newly created collider.

Add Collider

Add all

6. You can now expand the list of Colliders and see your colliders there

Colliders

Element O W default (Zibra Neural Collider)

Now your collider is ready to be used. You can set its transform in the editor, or move it
at runtime.
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Collider parometers

e Fluid Friction

Fluid Friction

Controls the surface friction of the collider, used for liquid interaction.

e Force Interaction

Force Interaction

Controls whether liquid can apply force back to the object. You need to add a
rigidbody component to the object that has a collider for liquid to apply force to.

e Inverse SDF

Invert SOF

“Inverts” the collider. E.g. in the case of a sphere, liquid will only be allowed
inside of that sphere.

K . U 2N



LIBBSLIBBRA"

e Chosen SDF Type (Analytic only)
Chosen SDF Type

Fluid Friction »  Sphere
Force Interaction

Invert SDF

Box
Capsule

' Default-Material | Torus

Cylinder

Select the shape of the Analytic collider.

e Generate Collider/Regenerate Collider (button, Neural only)

Generate collider

Generates a new, or regenerates an existing Neural collider. You'll need to
manually regenerate the collider if you change the mesh.

e Add Unity Collider (button, Neural only)

Add Unity Collider

Adds a Mesh collider, for the GameObiject to collide with other meshes. Not
required if you don’t want liquid colliders to collide with non liquid objects. Only
shown if you don’t already have a Mesh collider.
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Zibra Liquid has many kinds of manipulators: Emitter, Void, Detector, Force Field

Emitter

Liquid emitters are used for emitting liquid, if you want to spawn liquid you need these.
When you first create Zibra Liquid, the Emitter is automatically created and added to it.
If you don’t need additional ones you can skip adding additional emitters and go right

to Emitter parameters

Adding emitter

1. Right click on your Zibra Liquid instance, and select Zibra -> Zibra Liquid
Emitter

Rename
Duplicate
Delete

Select Children
Set as Default Parent

Create Empty
Create Empty Parent
3D Object
Effects
Light
Audio
Video
ul
Ul Toolkit
Zibra Liquid
Camera

Visual Scripting Scene Variables Zibra Liquid Void
Move To View Zibra Liquid Detector
Align With View Zibra Liquid Force Field
Align View to Selected

Toggle Active State

Properties...

That will automatically add a new emitter to your liquid.
Alternatively, you can:

K . U 2N
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1. Right click in Hierarchy (not on the Zibra Liquid instance) and select Zibra ->
Zibra Liquid Emitter

Duplicate

Delete

Create Empty

3D Object

Effects

Light

Audio

Video

]

Ul Toeolkit

Zibra Liquid

Camera

Visual Scripting Scene Variables Zibra Liquid Veid
Zibra Liquid Detector
Zibra Liquid Force Field

2. Open your Zibra Liquid instance in Inspector, and press the “Add” button for
your newly created emitter, under the Manipulators list.

Manipulators

Add Manipulator

Add all
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Emitter porometers

Emitter statistics (read only)

Total amount of created particles: O

Amount of created particles per frame: 0

When you start the play mode you’ll be able to keep track of how many
particles were emitted. You can also access those values via scripts, via
“createdParticlesTotal” and “createdParticlesPerFrame” attributes.

e Volume Per Sim Time

Volume Per Sim Time

Amount of liquid that is emitted per unit of Simulation Time.

e Initial Velocity

Initial Velocity

Initial speed of the generated particles.

Emitter’s transform changed via changing GameObject’s transform.

Void

Voids are used to destroy liquid. Since there’s a limit to the maximum number of
particles in Zibra Liquid instance, you need to destroy particles for your emitters to
keep emitting liquid continuously. But if it’s fine for you that the emitters will stop at
some point, the usage of voids is optional.
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Adding Void
1. Right click on your Zibra Liquid instance, and select Zibra -> Zibra Liquid Void

bra Liquid 2

Rename
Duplicate
Delete

Select Children
Set as Default Parent

Create Empty
Create Empty Parent
3D Object
Effects
Light
Audio
Video
Ul
Ul Toolkit
Zibra Liquid
Camera Zibra Liquid Emitter
Visual Scripting Scene Variables -
Move To View Zibra Liquid Detector
Align With View Zibra Liquid Force Field
Align View to Selected

Toggle Active State

Properties...

That will automatically add a new void to your liquid.
Alternatively, you can:

1. Right click in Hierarchy (not on the Zibra Liquid instance) and select Zibra ->
Zibra Liquid Void.

K . U 2hSEY.
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Duplicate

Delete

Create Empty

3D Object

Effects

Light

Audic

Video

Ul

Ul Toelkit

Zibra Liquid

Carnera Zibra Liquid Emitter

Visual Scripting Scene Variables
Zibra Liquid Detector
Zibra Liquid Force Field

2. Open your Zibra Liquid instance in Inspector, and press the “Add” button for
your newly created void under the Manipulators list.

Manipulators

Add Manipulator

Add all
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void porometers

e Void statistics (readonly)

Total amount of deleted particles: 0

Deleted particles per frame: 0

When you start play mode you’ll be able to keep track of how many particles

were deleted. You can also access those values via scripts, via

“deletedParticleCountTotal” and “deletedParticle CountPerFrame” attributes.
e Void’s transform changed via changing GameObject’s transform

Detector
Detector is used to detect how many liquid particles are in a specified volume.

Adding Detector

1. Right click on your Zibra Liquid instance, and select Zibra -> Zibra Liquid
Detector

Rename
Duplicate
Delete

Select Children
Set as Default Parent

Create Empty
Create Empty Parent
30 Object
Effects
Light
Audio
Video
Ul
Ul Toolkit
Zibra Liquid
Camera Zibra Liquid Emitter
Visual Scripting Scene Variables Zibra Liguid Void
Move To View
Align With View Zibra Liguid Force Field
Align View to Selected
Teggle Active State

Properties...
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That will automatically add a new detector to your liquid.
Alternatively, you can:
1. Right click in Hierarchy (not on Zibra Liquid instance) and select Zibra -> Zibra

Duplicate

Delete

Create Empty
3D Object
Effects
Light
Audio
Video
ul
Ul Toolkit
Zibra Liquid
Camera Zibra Liquid Emitter
Visual Scripting Scene Variables Zibra Liguid Void

Zibra Liquid Force Field

2. Open your Zibra Liquid instance in Inspector, and press the “Add” button for
your newly created Detector under Manipulators list.

Manipulators

Add Manipulator

Add all

Detector parometers
e Detected particle count (read only)

Amount of particles inside the detector: 0

When you start play mode you’ll be able to keep track of how many particles
are inside the detector. You can also access those values via scripts, via the
“particlesinside” attribute.

e Detectors' transform changed via changing GameObiject’s transform.

K . U 2hEY.
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Force fField

Force fields are used to apply force to liquid in a specific way, and in a specific region.
You can for example use force fields to create radial gravity, to use instead of the
default vector one. Or you can create a fountain by putting a force field that pushes
liquid up in the body of water.

Adding a Force Field

1. Right click on your Zibra Liquid instance, and select Zibra -> Zibra Liquid Force

ibra Liquid 2

Rename
Duplicate
Delete

Select Children
5et as Default Parent

Create Empty
Create Empty Parent
3D Object
Effects
Light
Audic
Video
Ul
Ul Toolkit
Zibra Liquid
Carera Zibra Liquid Emitter
Visual Scripting Scene Variables Zibra Liquid Void
Move To View Zibra Liquid Detector
Align With View

Align View to Selected

Toggle Active State

Properties..,

That will automatically add a new detector to your liquid.
Alternatively, you can:

K . UY 2y
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1. Right click in Hierarchy (not on Zibra Liquid instance) and select Zibra -> Zibra
Liquid Force Field

Duplicate
Delete

Create Emnpty
3D Object
Effects
Light
Audio
Video
]
Ul Toolkit
Zibra Liquid

Camera Zibra Liquid Emitter

Wisual Scripting Scene Variables Zibra Liquid Void
Zibra Liquid Detector

Zibra Liguid Force Field

2. Open your Zibra Liquid instance in Inspector, and press the “Add” button for
your newly created Force Field under Manipulators list.

Manipulators

Add Manipulator

Add all
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Force Field porometers
o Type

Radial

" Radial

Dhrectional

Distance Decay :
- =¥ Swirl

Configures how Force Field applies force to liquid.

Radial - pushes or pulls liquid towards the Force Field.

Directional - pushes liquid in a specified direction.

Swirl - creates a whirlpool force around the Force Field.

In the case of the Directional and Radial settings, the direction can be adjusted
by rotating the Force Field.

e Shape

Shape Sphere

Strength v  Sphere
Distance Decay Cube

Configures which shape the Force Field will have. Important for the distance
between the particle and Force Field calculation.

e Strength

Strength

Configures how strong the strength of the force applied by Force Field will be.
Can be negative to reverse direction. (For radial type, positive force is pulling,
and negative is pushing)

e Distance decay

Distance Decay

Configures how fast the force strength decays with the distance from the Force
Field.
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Liquid Initial Stote Balkang

(experimental)

If you want to have a Zibra Liquid instance pre-filled on startup you will need to use
Initial State baking.

After baking, the Zibra Liquid instance will remember its initial state and will start
simulation from it. Note that we do not support baking animation, simulation over time,
etc. Simulation itself is always performed on the device in real time, only the initial
state is baked.

Initial State Baking will simulate the first N seconds of your liquid instance, save it, and
simulation in play mode will start from that point.

Note that after changing some parameters you’ll have to rebake your liquid,
specifically: Grid Resolution, Container Size (in case you changed the size
non-uniformly, and as a result changed the Effective grid resolution), Max particle
count (in case your baked state has more particles that the current max number).

To bake initial state:
1. If you haven't already, add all emitters, voids, and colliders that you are going to
have to your liquid.
2. Open the baking utility and select your Zibra Liquid instance to bake.
There are 2 options to do it:
2.1.  Viathe Zibra Liquid Inspector
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2.1.1. Open the Zibra Liquid Inspector

& v Zibra Liquid

Fa" Edit Container Area
Container Size
Colliders
Listis Empty
Add Collider
Theli empty.

Manipulators

Before Forward Alpha
Current render pipeline

Approximate VRAM footprint

2.1.2.
Initial Stat

Baked Initial State A

Open Zibra Liquids Baking Utility (experimental)

2.1.3. Press “Open Zibra Liquids Baking Utility (experimental)”

2.2.  Via Unity’s menu
2.2.1. Press “Zibra Al -> Zibra Al - Liquids -> Baking Ultility
(experimental)”
Zibra Al Utilities Window H_elp

Zibra Al - Liquids Info

Litility (experimental]
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2.2.2. Ifthe Zibra Liquid instance wasn’t selected automatically, select
the Liquid Instance you want to bake.

Zibra Liguids Baking Utility...

salact tha Zibra Liquid instanca.

Mane (Zibra Liquid)

3. Now you see the Baking Utility window

Liguid Instance: Z Zibra Liguid 2 (Zibra Liguid) @

Run Simulation

Simulation time | ds) 2

Use project fixed timestep +

Baked Initial State Asset  Mone (Text

4. Set the Simulation time to the number of seconds you want to simulate.

5. (optional) If you want to run a baking simulation with specific timestamp, you
can disable “Use project fixed timestep” and set your desired “Simulation
timestep”

Zibra Liguids Baking Utility...

Liguid Instance: Z Zibra Liquid 2 {Zibra Liguid) @

Run Simulation
Simulation time |

limestep

Simulation timestep
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6. Press “Run Simulation’.
You'll see the simulation running in Scene/Game view (only Game view on
URP)

7.  (optional) If you want to run the simulation further, set the Simulation time to the
amount of time you want to run simulation forward, and press “Run Simulation
Forward”.

Zibra Liguids Baking Utility...

Q-

Liguid Instance: Z Zibra Liquid 2 {Zibra Liguid) @

Run Simulation Forward
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8. (optional) If you simulated too far, and want to start over, press “Stop” and go
back to step 4

Zibra Liguids Baking Utility...

Liguid Instance: Z Zibra Liguid 2 (Zibra Liguid) @&

Run Simulation Forward

Stop

Liguid Instance: Z Zibra Liquid 2 {Zibra Liguid) @

Run Simulation Forward

Baked Initial State

That will save the new state to the file in the subdirectory next to your scene
file. e.g. for Liquid Instance “ZibraLiquid1”in “/Assets/NewScene.unity” scene,
liquid baked state will be saved into /Assets/NewScene/” folder as
“ZibralLiquid1BakedState.bytes”.

K . UY 2N
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9.1. If you already had a previous saved state you’ll have 2 buttons: “Save
new state” and “Overwrite existing state”.

Zibra Liguids Baking Utility...

Qi

Liguid Instance: Z Zibra Liguid 2 {Zibra Liguid) @

Run Simulation Forward
Stop
Simulation time (seconds) |2

ixed timestep +

Save new state

Overwrite existing state

Baked Initial State Asset B Zibra Liguid 2BakedState

9.2. “Save new state” always creates a new file, while “Overwrite existing
state” always overwrites the old file with a new state.

10. (optional) After you are done with baking, press “Stop” to stop the liquid
simulation and unlock the parameters that are disabled when the liquid is “live”.

Next time you’ll change a scene or enter playmode this state will reset, so you
usually don’t need to manually stop it.
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Access to Neural Collider generation requires registering, since that feature requires
access to Zibra Al’s server for processing.
To register your copy of Zibra Liquids:
1. Make sure that you launched the Unity Editor via Unity Hub and are logged into
the correct Unity account.
2. Press “Zibra Al -> Zibra Al - Liquids -> Info”

o Zibra Al Utilities Window Help

Zibra Al - Liguids [ Info |

Baking Utility (experimental)

S Cene & Game

3. In the opened window press “Open registration form”

Info

Registration
Open registration form
Server Authentication Key

Check Authentication Key

4. Fill out the registration form. Note that you’ll need an Invoice number. It is not
the same number as the order number. You can find your invoice number in
your emails. It has the following format: “IN012345678901".

5. After filling out the form, wait for an email with a Server Authentication Key.

6. Enter the key into the “Server Authentication Key” field and press Check
Authentication Key.

Registration
| Open registration form
Server Authentication Key

Check Authentication Key

7. After that you should see this message

Registration

After registration you can generate neural colliders. Note that generating neural
colliders sends your mesh to the Zibra Al servers for processing.

K . UY 2.
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If you have any issues that you think are the fault of Zibra Liquids, please feel free to
contact us on Discord

If you are going to reach out to us for troubleshooting, please export the diagnostics
info via this button and send it to us

o Zibra A Window Help

Zibra Al - Liguids Info
Baking Utility (experimental)

Generate all Meural colliders in the Scene

diagnostic information to clip

Some common issues you may have and ways to troubleshoot:
e Check whether you have any errors in the Liquid Instance
e.g.
Z + Zibra Liquid

Reflection probea is not sat. Liquid will r

e On URP, not adding “URP Liquid Rendering Component”
See Additional setup on URP

e Trying to use Zibra Liquids on an unsupported platform (Android, Oculus/Meta
Quest 2) or with unsupported features (VR)
See System Requirements.
e On HDRRP, the Liquid is too bright
Decrease “Reflection color’ in Liquid Instance’s Material Parameters
e Black artifacts on liquid near surface discontinuity
Decrease “Blur radius” in Liquid Instance



https://discord.gg/f3yUG3JvWY

